using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(Crude Oil).*$";
string input = @"Crude Oil
aCrude Oil
Crude Oila
aCrude Oila
Bakken Crude Oil:
a Crude Oil a
C rude Oil
a Crude Oil
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}