re = /^.*(Crude Oil).*$/m
str = 'Crude Oil
aCrude Oil
Crude Oila
aCrude Oila
Bakken Crude Oil:
a Crude Oil a
C rude Oil
a Crude Oil
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end