$re = '/^.*(Crude Oil).*$/m';
$str = 'Crude Oil
aCrude Oil
Crude Oila
aCrude Oila
Bakken Crude Oil:
a Crude Oil a
C rude Oil
a Crude Oil
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);