package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*(Crude Oil).*$`)
var str = `Crude Oil
aCrude Oil
Crude Oila
aCrude Oila
Bakken Crude Oil:
a Crude Oil a
C rude Oil
a Crude Oil
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}