using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(|s):\/\/([^/]+[.])*example.com";
string input = @"http://api.example.com/...
http://preview.example.com/...
http://www.example.com/...
http://purhcase.example.com/...
https://www.google.com/search?dcr=0&source=hp&q=www.example.com&oq=www.example.com&gs_l=psy-ab.3..0l10.1064.1064.0.1493.2.1.0.0.0.0.120.120.0j1.1.0....0...1.1.64.psy-ab..1.1.120.0...0.KLG4Wny_yFA";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}