re = /^http(|s):\/\/([^\/]+[.])*example.com/im
str = 'http://api.example.com/...
http://preview.example.com/...
http://www.example.com/...
http://purhcase.example.com/...
https://www.google.com/search?dcr=0&source=hp&q=www.example.com&oq=www.example.com&gs_l=psy-ab.3..0l10.1064.1064.0.1493.2.1.0.0.0.0.120.120.0j1.1.0....0...1.1.64.psy-ab..1.1.120.0...0.KLG4Wny_yFA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end