// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^http(|s):\/\/([^/]+[.])*example.com").unwrap();
let string = "http://api.example.com/...
http://preview.example.com/...
http://www.example.com/...
http://purhcase.example.com/...
https://www.google.com/search?dcr=0&source=hp&q=www.example.com&oq=www.example.com&gs_l=psy-ab.3..0l10.1064.1064.0.1493.2.1.0.0.0.0.120.120.0j1.1.0....0...1.1.64.psy-ab..1.1.120.0...0.KLG4Wny_yFA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}