import Foundation
let pattern = #"^http(|s):\/\/([^/]+[.])*example.com"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
http://api.example.com/...
http://preview.example.com/...
http://www.example.com/...
http://purhcase.example.com/...
https://www.google.com/search?dcr=0&source=hp&q=www.example.com&oq=www.example.com&gs_l=psy-ab.3..0l10.1064.1064.0.1493.2.1.0.0.0.0.120.120.0j1.1.0....0...1.1.64.psy-ab..1.1.120.0...0.KLG4Wny_yFA
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)