use strict;
my $str = 'http://api.example.com/...
http://preview.example.com/...
http://www.example.com/...
http://purhcase.example.com/...
https://www.google.com/search?dcr=0&source=hp&q=www.example.com&oq=www.example.com&gs_l=psy-ab.3..0l10.1064.1064.0.1493.2.1.0.0.0.0.120.120.0j1.1.0....0...1.1.64.psy-ab..1.1.120.0...0.KLG4Wny_yFA';
my $regex = qr/^http(|s):\/\/([^/]+[.])*example.com/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}