#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*\-\-)(?!.*\-.+\-.*\-)(?!-)[a-z0-9-]{0,52}(?<!-)$"
Local $sString = "MycatBilly-Bobhas9lives" & @CRLF & _
"nlyallows52total" & @CRLF & _
"-thisshouldnotmatch" & @CRLF & _
"norshouldthis-" & @CRLF & _
"thisis--anotherbaddie" & @CRLF & _
"nothing-wrong-here" & @CRLF & _
"but-this-is-anono" & @CRLF & _
"thisistoolongfartoolongtomeetthemaximumlengthrequirement" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")