using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\-\-)(?!.*\-.+\-.*\-)(?!-)[a-z0-9-]{0,52}(?<!-)$";
string input = @"MycatBilly-Bobhas9lives
nlyallows52total
-thisshouldnotmatch
norshouldthis-
thisis--anotherbaddie
nothing-wrong-here
but-this-is-anono
thisistoolongfartoolongtomeetthemaximumlengthrequirement
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}