re = /^(?!.*\-\-)(?!.*\-.+\-.*\-)(?!-)[a-z0-9-]{0,52}(?<!-)$/mi
str = 'MycatBilly-Bobhas9lives
nlyallows52total
-thisshouldnotmatch
norshouldthis-
thisis--anotherbaddie
nothing-wrong-here
but-this-is-anono
thisistoolongfartoolongtomeetthemaximumlengthrequirement
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end