import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\-\\-)(?!.*\\-.+\\-.*\\-)(?!-)[a-z0-9-]{0,52}(?<!-)$";
final String string = "MycatBilly-Bobhas9lives\n"
+ "nlyallows52total\n"
+ "-thisshouldnotmatch\n"
+ "norshouldthis-\n"
+ "thisis--anotherbaddie\n"
+ "nothing-wrong-here\n"
+ "but-this-is-anono\n"
+ "thisistoolongfartoolongtomeetthemaximumlengthrequirement\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}