#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[.*?\]|https?://[\w\.]+/\h"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor " & @CRLF & _
"[ABCDEFGHIJKLMNO] incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, " & @CRLF & _
"quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat." & @CRLF & _
"Duis aute irure http://domain.com/ dolor in reprehenderit in voluptate velit esse cillum " & @CRLF & _
"dolore eu :fugiat: nulla pariatur. Excepteur sint occaecat :cupidatat [non] proident:, " & @CRLF & _
"sunt in culpa qui officia deserunt mollit anim id est laborum. https://foo.co.uk/ the end."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")