import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.*?\\]|https?://[\\w\\.]+/\\h";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor \n"
+ "[ABCDEFGHIJKLMNO] incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, \n"
+ "quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.\n"
+ "Duis aute irure http://domain.com/ dolor in reprehenderit in voluptate velit esse cillum \n"
+ "dolore eu :fugiat: nulla pariatur. Excepteur sint occaecat :cupidatat [non] proident:, \n"
+ "sunt in culpa qui officia deserunt mollit anim id est laborum. https://foo.co.uk/ the end.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}