const regex = new RegExp('\\[.*?\\]|https?://[\\w\\.]+/\\h', 'g')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor
[ABCDEFGHIJKLMNO] incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam,
quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure http://domain.com/ dolor in reprehenderit in voluptate velit esse cillum
dolore eu :fugiat: nulla pariatur. Excepteur sint occaecat :cupidatat [non] proident:,
sunt in culpa qui officia deserunt mollit anim id est laborum. https://foo.co.uk/ the end.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}