// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[.*?\]|https?://[\w\.]+/\h").unwrap();
let string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor
[ABCDEFGHIJKLMNO] incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam,
quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure http://domain.com/ dolor in reprehenderit in voluptate velit esse cillum
dolore eu :fugiat: nulla pariatur. Excepteur sint occaecat :cupidatat [non] proident:,
sunt in culpa qui officia deserunt mollit anim id est laborum. https://foo.co.uk/ the end.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}