using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[.*?\]|https?://[\w\.]+/\h";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor
[ABCDEFGHIJKLMNO] incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam,
quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure http://domain.com/ dolor in reprehenderit in voluptate velit esse cillum
dolore eu :fugiat: nulla pariatur. Excepteur sint occaecat :cupidatat [non] proident:,
sunt in culpa qui officia deserunt mollit anim id est laborum. https://foo.co.uk/ the end.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}