#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\bfoo\b((?!\bbar\b).)*?\bfoo\b"
Local $sString = "foo" & @CRLF & _
"jumped" & @CRLF & _
"over" & @CRLF & _
"the" & @CRLF & _
"lazy" & @CRLF & _
"foo" & @CRLF & _
"foo" & @CRLF & _
"jumped" & @CRLF & _
"over" & @CRLF & _
"the" & @CRLF & _
"bar" & @CRLF & _
"foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")