const regex = /\bfoo\b((?!\bbar\b).)*?\bfoo\b/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bfoo\\b((?!\\bbar\\b).)*?\\bfoo\\b', 'gms')
const str = `foo
jumped
over
the
lazy
foo
foo
jumped
over
the
bar
foo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}