$re = '/\bfoo\b((?!\bbar\b).)*?\bfoo\b/ms';
$str = 'foo
jumped
over
the
lazy
foo
foo
jumped
over
the
bar
foo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);