using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bfoo\b((?!\bbar\b).)*?\bfoo\b";
string input = @"foo
jumped
over
the
lazy
foo
foo
jumped
over
the
bar
foo";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}