re = /\bfoo\b((?!\bbar\b).)*?\bfoo\b/m
str = 'foo
jumped
over
the
lazy
foo
foo
jumped
over
the
bar
foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end