import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SUPERTYPE OF\\s\\(\\s*(\\w+)\\s*\\)";
final String string = " ENTITY solid_with_hole\n"
+ " ABSTRACT SUPERTYPE OF ( \n"
+ " solid_with_stepped_round_hole)\n"
+ " SUBTYPE OF ( solid_with_depression );\n"
+ " END_ENTITY;\n\n"
+ " ENTITY solid_with_hole\n"
+ " ABSTRACT SUPERTYPE OF ( \n"
+ " solid_with_stepped_round_hole)\n"
+ " SUBTYPE OF ( solid_with_depression );\n"
+ " END_ENTITY;\n\n"
+ " ENTITY solid_with_hole\n"
+ " ABSTRACT SUPERTYPE OF (solid_with_stepped_round_hole)\n"
+ " SUBTYPE OF ( solid_with_depression );\n"
+ " END_ENTITY;\n\n"
+ " ENTITY solid_with_hole\n"
+ " ABSTRACT SUPERTYPE OF ( solid_with_stepped_round_hole )\n"
+ " SUBTYPE OF ( solid_with_depression );\n"
+ " END_ENTITY;\n\n"
+ " ENTITY solid_with_hole\n"
+ " SUPERTYPE OF ( solid_with_stepped_round_hole \n\n\n\n"
+ ")\n"
+ " SUBTYPE OF ( solid_with_depression );\n"
+ " END_ENTITY;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}