re = /SUPERTYPE OF\s\(\s*(\w+)\s*\)/m
str = ' ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF ( solid_with_stepped_round_hole )
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
SUPERTYPE OF ( solid_with_stepped_round_hole
)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end