// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)SUPERTYPE OF\s\(\s*(\w+)\s*\)").unwrap();
let string = " ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (
solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF (solid_with_stepped_round_hole)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
ABSTRACT SUPERTYPE OF ( solid_with_stepped_round_hole )
SUBTYPE OF ( solid_with_depression );
END_ENTITY;
ENTITY solid_with_hole
SUPERTYPE OF ( solid_with_stepped_round_hole
)
SUBTYPE OF ( solid_with_depression );
END_ENTITY;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}