using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",.*\s([\d-]+)(?:$|\s)";
string input = @"2520222 Rubble,Barney 1134525
1524356 Mudd,Harry S 14-40525 111.11
2324316 Mudd,Mary R 12-40000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}