$re = '/,.*\s([\d-]+)(?:$|\s)/m';
$str = '2520222 Rubble,Barney 1134525
1524356 Mudd,Harry S 14-40525 111.11
2324316 Mudd,Mary R 12-40000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);