use strict;
my $str = '2520222 Rubble,Barney 1134525
1524356 Mudd,Harry S 14-40525 111.11
2324316 Mudd,Mary R 12-40000';
my $regex = qr/,.*\s([\d-]+)(?:$|\s)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}