// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\t([^: ]{1,5}):([^: ]*):([^: ]*):([^: ]*):([^: ]*):([^: ]*):([^: \t]*)").unwrap();
let string = "1 13302 rs180734498 C T 564172 VQSRTrancheSNP99.60to99.80 BaseQRankSum=0.35;ClippingRankSum=0.062;DB;ExcessHet=0.0012;FS=5.483;InbreedingCoeff=0.0501;MQ=26.09;MQ0=0;MQRankSum=-3.805;QD=6.19;ReadPosRankSum=-1.494;SOR=1.191;VQSLOD=-0.9551;culprit=QD;DP=182805;AF=0.279;MLEAC=1817;MLEAF=0.279;AN=4308;AC=1464 GT:AD:DP:GQ:PGT:PID:PL ./.:0,0:0:0::.:. ./.:0,0:0:0:.:.:. ./.:0,0:0:0::.:. ./.:0,0:0:0:0,4,9:.:.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}