#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+(.log|.txt)(.\d)?$"
Local $sString = "test.jpg" & @CRLF & _
"abc.123" & @CRLF & _
"output.log" & @CRLF & _
"output.log.1" & @CRLF & _
"output.log.2.5.txt" & @CRLF & _
"output.log.2.tar.gz" & @CRLF & _
"output.1.txt" & @CRLF & _
"output.txt" & @CRLF & _
"index.html" & @CRLF & _
"file.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")