using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+(.log|.txt)(.\d)?$";
string input = @"test.jpg
abc.123
output.log
output.log.1
output.log.2.5.txt
output.log.2.tar.gz
output.1.txt
output.txt
index.html
file.zip";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}