re = /^.+(.log|.txt)(.\d)?$/m
str = 'test.jpg
abc.123
output.log
output.log.1
output.log.2.5.txt
output.log.2.tar.gz
output.1.txt
output.txt
index.html
file.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end