import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+(.log|.txt)(.\\d)?$";
final String string = "test.jpg\n"
+ "abc.123\n"
+ "output.log\n"
+ "output.log.1\n"
+ "output.log.2.5.txt\n"
+ "output.log.2.tar.gz\n"
+ "output.1.txt\n"
+ "output.txt\n"
+ "index.html\n"
+ "file.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}