package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]|1[0-2]):[0-5][0-9][ ]?([AP]M|[ap]m)`)
var str = `1:29 am
12:56PM
9:12 PM
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}