const regex = /^([0-9]|1[0-2]):[0-5][0-9][ ]?([AP]M|[ap]m)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]|1[0-2]):[0-5][0-9][ ]?([AP]M|[ap]m)', 'gm')
const str = `1:29 am
12:56PM
9:12 PM
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}