// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9]|1[0-2]):[0-5][0-9][ ]?([AP]M|[ap]m)").unwrap();
let string = "1:29 am
12:56PM
9:12 PM
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}