$re = '/^([0-9]|1[0-2]):[0-5][0-9][ ]?([AP]M|[ap]m)/m';
$str = '1:29 am
12:56PM
9:12 PM
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);