package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)–.*?–`)
var str = `Человек – родовое понятие, указывающее на отнесенность существа к высшей степени развития живых организмов – человеческому роду.
Самопознание – процесс познания человеком самого себя.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}