// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)–.*?–").unwrap();
let string = "Человек – родовое понятие, указывающее на отнесенность существа к высшей степени развития живых организмов – человеческому роду.
Самопознание – процесс познания человеком самого себя.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}