const regex = new RegExp('–.*?–', 'gm')
const str = `Человек – родовое понятие, указывающее на отнесенность существа к высшей степени развития живых организмов – человеческому роду.
Самопознание – процесс познания человеком самого себя.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}