re = /–.*?–/m
str = 'Человек – родовое понятие, указывающее на отнесенность существа к высшей степени развития живых организмов – человеческому роду.
Самопознание – процесс познания человеком самого себя.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end