$re = '/–.*?–/m';
$str = 'Человек – родовое понятие, указывающее на отнесенность существа к высшей степени развития живых организмов – человеческому роду.
Самопознание – процесс познания человеком самого себя.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);