const regex = /([^\pL\pN\pS\pZ])|([\xC2\xA0])/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\pL\\pN\\pS\\pZ])|([\\xC2\\xA0])', 'u')
const str = `line_1
line_2`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);