use strict;
my $str = 'line_1
line_2';
my $regex = qr/([^\pL\pN\pS\pZ])|([\xC2\xA0])/up;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";